Sunday, January 17, 2016

My DisplayLink troubleshooting guide

I use Targus DisplayLink adapter for using my Win 10 ASUS laptop with multiple monitors. When things work, they work really well. But often they don't. And the problems are weird. All of a sudden, the adapter just stop working. How many times I try, nothing works, except when it starts working again. 

Here are some of my notes from my troubleshooting experience.
  • The adapter needs correct voltage to get detected the first time I am inserting the USB 3.0. Most of the time the voltage is there, and things work. But when it doesn't work, I have seen things kick in if I do a few of the below:
    • Let Laptop hard drive activity subside. That means the HDD LED is not active.
    • Power cycle through the DisplayLink adapter.
      • This sometimes still doesn't work because the power adapter that powers the DisplayLink adapter also powers the external monitors. 
    • Just detach the  mini plug from the power box of the DisplayLink adapter, and put that back in.
      • I have recently discovered this, and this seems to work well so far.
  • Once I did the last one, and the monitors started misbehaving. Specifically, the two external monitors constantly started switching between #1 and #2. I have a Dell 23' monitor connected through HDMI, and a Dell 19' connected through DVI. The switching was rapid (e.g., once every second or so) and very weird, haven't seen this before. I had to detach my 2nd monitor and reattach it back in order to get things working again.
  • [Update - March 4, 2016] New issue: when I inserted the USB cable, I started getting the following error: "USB Device Malfunctioning", and details had something like "Device Descriptor request failed". I tried a bunch of stuff, including the usual uninstall-reinstall etc., but finally what worked is a power cycling of the display adapter.